summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Udvare <audvare@gmail.com>2020-12-29 15:18:06 -0500
committerMichael Stahl <michael.stahl@allotropia.de>2021-02-09 18:36:23 +0100
commitd1dc51f95f9e831aa6adbbeff549c2017d2dfd82 (patch)
tree4d5756cbe0f8035f1eaf268e75b49cb59e6a85dc /configure.ac
parentd03308ad9520d97d948e1143a59f0c259f18ba36 (diff)
configure.ac: allow --enable-python=system on macOS if PYTHON is non-empty
This will work as long as a valid Python is in PATH, such as /usr/bin/python3 from Xcode or another version in some prefix like /opt/local. Change-Id: Ic967c3ce2f9949d94c11c3449363841a1565cfa9 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108486 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e6607334b067..78bb7998e62c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9238,8 +9238,9 @@ AC_SUBST(XMLLINT)
# Optionally user can pass an option to configure, i. e.
# ./configure PYTHON=/usr/bin/python
# =====================================================================
-if test $_os = Darwin -a "$enable_python" != no -a "$enable_python" != fully-internal -a "$enable_python" != internal; then
+if test $_os = Darwin -a "$enable_python" != no -a "$enable_python" != fully-internal -a "$enable_python" != internal -a "$enable_python" != system; then
# Only allowed choices for macOS are 'no', 'internal' (default), and 'fully-internal'
+ # unless PYTHON is defined as above which allows 'system'
enable_python=internal
fi
if test "$build_os" != "cygwin" -a "$enable_python" != fully-internal; then
@@ -9311,7 +9312,7 @@ fully-internal)
;;
system)
AC_MSG_RESULT([system])
- if test "$_os" = Darwin; then
+ if test "$_os" = Darwin -a -z "$PYTHON"; then
AC_MSG_ERROR([--enable-python=system doesn't work on macOS because the version provided is obsolete])
fi
;;