summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-06-16 15:49:07 +0200
committerStephan Bergmann <sbergman@redhat.com>2017-11-26 18:29:40 +0100
commit7e222aff21d82a818e3a0f72f7e4d7e2a83c7274 (patch)
tree2c9dcdf3f6b046f269d23f0bef5f1bc65ffbc2e5 /configure.ac
parentae16870b2c84c116cde8279a47db106a4fa9d529 (diff)
Remove dated configure check after LO 6.0 branch-off
See c127c19de62201b49b6647ef3ee8b08ae49da852 "Remove HAVE_CXX11_REF_QUALIFIER, always true now". By now, any outdated builders where this would fail should have been identified and taken care of. Change-Id: I5f823b48b40dd6a20991ebb118e077a0e88aacb1 Reviewed-on: https://gerrit.libreoffice.org/38887 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 3d0e09733ec5..4ff7655c0f36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6172,23 +6172,6 @@ if test "$cxx14_constexpr" = yes; then
AC_DEFINE([HAVE_CXX14_CONSTEXPR])
fi
-AC_MSG_CHECKING([whether $CXX supports C++11 ref-qualifier])
-save_CXXFLAGS=$CXXFLAGS
-CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
-AC_LANG_PUSH([C++])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- struct S {
- void f() &;
- void f() &&;
- };
- ]])], [cxx11_ref_qualifier=yes], [cxx11_ref_qualifier=no])
-AC_LANG_POP([C++])
-CXXFLAGS=$save_CXXFLAGS
-AC_MSG_RESULT([$cxx11_ref_qualifier])
-if test "$cxx11_ref_qualifier" = no; then
- AC_MSG_ERROR([Your $CXX does not support C++11 ref-qualifiers. This is no longer supported.])
-fi
-
dnl _Pragma support (may require C++11)
if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_CHECKING([whether $CXX supports _Pragma operator])