summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2015-06-18 10:15:28 +0200
committerDavid Tardon <dtardon@redhat.com>2015-06-18 10:16:02 +0200
commit2703f4d84323c718f6fbefc8699457ab2a7aacbf (patch)
tree76cb43cac734af198df1548392b8b7ae6af50566 /configure.ac
parentf3b51162b68acc7b22c2c5b41a8b29038153afab (diff)
continue to support glew 1.10
Change-Id: I951c04e7d0039f1e38e3bcb2ea7e0f7c33293b9b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ec301ca9a6a..6a30d8ac4735 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8699,6 +8699,9 @@ dnl ===================================================================
dnl Check for system glew
dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([glew], [GLEW], [glew >= 1.10.0])
+AS_IF([test "$with_system_glew" = "yes"],
+ [PKG_CHECK_EXISTS([glew >= 1.12.0], [AC_DEFINE([HAVE_GLEW_1_12])])],
+ [AC_DEFINE([HAVE_GLEW_1_12])])
dnl ===================================================================
dnl Check for system vigra
@@ -13075,6 +13078,7 @@ AC_CONFIG_HEADERS([config_host/config_orcus.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])
AC_CONFIG_HEADERS([config_host/config_mingw.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])
+AC_CONFIG_HEADERS([config_host/config_opengl.h])
AC_CONFIG_HEADERS([config_host/config_options.h])
AC_CONFIG_HEADERS([config_host/config_test.h])
AC_CONFIG_HEADERS([config_host/config_telepathy.h])