summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2013-01-03 20:15:21 +0100
committerLuboš Luňák <l.lunak@suse.cz>2013-01-04 15:27:24 +0100
commit217e3f2ea1e8983328364607f244daceeafca167 (patch)
tree136686e0e8faadfcc91c8a24a74318cf550700b4 /configure.ac
parent1cec392ef50699cc0f310823e4e5fdbb9b272f0f (diff)
better handling of which files are processed by clang plugins
Check that only LO's files are processed, as there's no point otherwise. Also warn about files in workdir/solver/builddir, as those are either generated or copies. Try to automatically match include files from solver to srcdir though, as that's where include files are usually included from :(. Change-Id: Ie8389e903f623a9d0e75015091acc0da78e76c3a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f9527d67f99..bd5b0749240e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,6 +107,7 @@ AC_SUBST(BUILDDIR)
AC_SUBST(EXEEXT_FOR_BUILD)
AC_SUBST(x_Cygwin)
AC_DEFINE_UNQUOTED(SRCDIR,"$SRC_ROOT")
+AC_DEFINE_UNQUOTED(BUILDDIR,"$BUILDDIR")
if test "z$EUID" = "z0" -a "`uname -o 2>/dev/null`" = "Cygwin"; then
AC_MSG_ERROR([You must build LibreOffice as a normal user - not using an administrative account])
@@ -4092,6 +4093,8 @@ AC_SUBST(P_SEP)
AC_SUBST(SOLARVER)
AC_SUBST(WORKDIR)
AC_SUBST(PLATFORMID)
+AC_DEFINE_UNQUOTED(OUTDIR,"$OUTDIR")
+AC_DEFINE_UNQUOTED(WORKDIR,"$WORKDIR")
dnl ===================================================================
dnl Test which package format to use