summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@openoffice.org>2010-06-22 16:19:42 +0200
committerRene Engelhard <rene@openoffice.org>2010-06-22 16:19:42 +0200
commita6afbb6d5c5f86a86521c8025ad21380c60bc7cf (patch)
tree76babed9b14bed2fb548d6f4ca75dd836e50303d /configure.in
parentded2aa39fe5ad0be3ebd0e42f9bf514f1248e2a0 (diff)
configure25: reject hsqldb 1.8.1.x
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 0f658c8cb..cf6516565 100644
--- a/configure.in
+++ b/configure.in
@@ -3990,7 +3990,7 @@ if test -n "$with_system_hsqldb" -o -n "$with_system_libs" && \
fi
AC_CHECK_FILE($HSQLDB_JAR, [],
[AC_MSG_ERROR(hsqldb.jar not found.)], [])
- AC_MSG_CHECKING([whether hsqldb is >= 1.8.0.9])
+ AC_MSG_CHECKING([whether hsqldb is 1.8.0.x])
export HSQLDB_JAR
if $PERL -e 'use Archive::Zip;
my $file = "$ENV{'HSQLDB_JAR'}";
@@ -4003,7 +4003,7 @@ if test -n "$with_system_hsqldb" -o -n "$with_system_libs" && \
($t, $version) = split (/:/,$line);
$version =~ s/^\s//;
($a, $b, $c, $d) = split (/\./,$version);
- if (($c == "0" && $d > "8") || $c > 0) {
+ if ($c == "0" && $d > "8") {
exit 0;
} else {
exit 1;
@@ -4015,7 +4015,7 @@ if test -n "$with_system_hsqldb" -o -n "$with_system_libs" && \
}'; then
AC_MSG_RESULT([yes])
else
- AC_MSG_ERROR([no, hsqldb >= 1.8.0.9 is needed])
+ AC_MSG_ERROR([no, you need hsqldb >= 1.8.0.9 but < 1.8.1])
fi
else
AC_MSG_RESULT([internal])