summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEbrahim Byagowi <ebrahim@gnu.org>2018-02-12 12:00:07 +0330
committerGitHub <noreply@github.com>2018-02-12 12:00:07 +0330
commit2efc8965506d8fd31934be1dba3322f922f3409d (patch)
tree6ed88ebc65e0fe5bdabca46f72092d917ecf0071 /configure.ac
parent82e04758c895ce2cd6bddde5f72e592c718fcb69 (diff)
Add --with-stdcpp for ossfuzzer and mupdf use (#770)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5a17cc1a..f77e0874 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,12 @@ m4_define([hb_libtool_current],
HB_LIBTOOL_VERSION_INFO=hb_libtool_current:hb_libtool_revision:hb_libtool_age
AC_SUBST(HB_LIBTOOL_VERSION_INFO)
+AC_ARG_WITH([stdcpp],
+ [AS_HELP_STRING([--with-stdcpp],
+ [Do not try suppressing linkage to libstdcpp])],,
+ [with_stdcpp=no])
+AM_CONDITIONAL(WITHSTDCPP, [test "x$with_stdcpp" = "xyes"])
+
# Documentation
have_gtk_doc=false
m4_ifdef([GTK_DOC_CHECK], [
@@ -80,12 +86,6 @@ if test "x$GCC" = "xyes"; then
# Make symbols link locally
LDFLAGS="$LDFLAGS -Bsymbolic-functions"
- # Make sure we don't link to libstdc++
- CXXFLAGS="$CXXFLAGS -fno-rtti -fno-exceptions"
-
- # No threadsafe statics and C++ as we do it ourselves
- CXXFLAGS="$CXXFLAGS -fno-threadsafe-statics"
-
# Assorted warnings
CXXFLAGS="$CXXFLAGS -Wcast-align"