summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2008-04-01 16:08:52 -0400
committerDavid Zeuthen <davidz@redhat.com>2008-04-01 16:08:52 -0400
commitac2c63385db4edd71536981eed65d72f367661d8 (patch)
treeb3d137f3d0768b86d3d2e8dc20358ddaeeba5837 /configure.in
parentff6736fb5ab04a117c55edee99ec9b61385e14b6 (diff)
default to use CK and PK by default and print warning if PK is not found
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 013e2b32..e76ff519 100644
--- a/configure.in
+++ b/configure.in
@@ -479,7 +479,7 @@ AC_DEFINE_UNQUOTED(DBUS_API_SUBJECT_TO_CHANGE, [], [DBUS API is subject to chang
# check for ConsoleKit
AM_CONDITIONAL(HAVE_CONKIT, false)
-AC_ARG_ENABLE(console-kit, [ --enable-console-kit Use ConsoleKit],enable_console_kit=$enableval,enable_console_kit=no)
+AC_ARG_ENABLE(console-kit, [ --enable-console-kit Use ConsoleKit],enable_console_kit=$enableval,enable_console_kit=yes)
msg_conkit=no
if test "x$enable_console_kit" != "xno"; then
AM_CONDITIONAL(HAVE_CONKIT, true)
@@ -524,7 +524,7 @@ AM_CONDITIONAL(BUILD_KEYMAPS, [test x$BUILD_KEYMAPS = xyes])
AM_CONDITIONAL(HAVE_POLKIT, [false])
AC_ARG_ENABLE([policy-kit],
AS_HELP_STRING([--enable-policy-kit], [Use PolicyKit]),
- [enable_policy_kit=$enableval], [enable_policy_kit=no])
+ [enable_policy_kit=$enableval], [enable_policy_kit=yes])
msg_polkit=no
if test "x$enable_policy_kit" != "xno"; then
if test "x$enable_console_kit" = "xno"; then
@@ -1106,6 +1106,15 @@ echo "
Building man pages: ${enable_man_pages}
"
+if test x${msg_polkit} = xno; then
+ echo "WARNING: PolicyKit is disabled. You need to manually edit the hal.conf"
+ echo " file to lock down the service. Failure to do so allows any"
+ echo " caller to make hald do work on their behalf which may be"
+ echo " a huge SECURITY HOLE. I repeat: YOU NEED TO EDIT THE FILE"
+ echo " hal.conf to match your distro/site to avoid NASTY SECURITY HOLES."
+ echo ""
+fi
+
if test x$BUILD_ACPI_IBM = xyes; then
echo "NOTE: Future Linux kernels may provide IBM ACPI events via a kernel."
echo " input device resulting in HAL emitting twice as many events as it"