summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDanny Kukawka <danny.kukawka@web.de>2008-08-25 12:58:43 +0200
committerDanny Kukawka <danny.kukawka@web.de>2008-08-25 12:58:43 +0200
commitaa673602a42b3fab01b14dfd2934e9f15e4c6428 (patch)
tree764bd365865a26cece5e67b49f6259b6a5570299 /configure.in
parentb068ea78116cb702c0647b0e7c355022b640d647 (diff)
added check for ConsoleKit >= v0.3.1 to configure
Added check for ConsoleKit >= v0.3.1 to configure to be able to differ between the versions due to API breakage.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d25a64bd..5cc6e5d3 100644
--- a/configure.in
+++ b/configure.in
@@ -486,6 +486,20 @@ if test "x$enable_console_kit" != "xno"; then
AM_CONDITIONAL(HAVE_CONKIT, true)
AC_DEFINE(HAVE_CONKIT, [], [Set if we use ConsoleKit])
msg_conkit=yes
+ # yes this is ugly, but there is no other way to get the version of CK
+ AC_MSG_CHECKING([if ConsoleKit version 0.3.0 or newer])
+ if $PKG_CONFIG --atleast-version=0.3.0 ck-connector; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_CK_0_3, 1, [Define to 1 if ConsoleKit is v0.3.0 or newer])
+ else
+ if $PKG_CONFIG --max-version=0.2.10 ck-connector; then
+ AC_MSG_RESULT([no])
+ else
+ #assume we have the latest version
+ AC_MSG_WARN([Couldn't detect ConsoleKit version, install the devel package, assume for now you use >= 0.3.0])
+ AC_DEFINE(HAVE_CK_0_3, 1, [Define to 1 if ConsoleKit is v0.3.0 or newer])
+ fi
+ fi
fi
AC_PATH_PROG(GPERF, [gperf], [no])