summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDanny Kukawka <danny.kukawka@web.de>2008-08-28 11:04:07 +0200
committerDanny Kukawka <danny.kukawka@web.de>2008-08-28 11:04:07 +0200
commit9e257137b2e699443358b0575cf881c84b75e617 (patch)
tree225342f0958828fcc410cb73bb896e7d172e9dcb /configure.in
parenta21abab0059e99fd690a1c9b6a7ed77ea7aa7bb9 (diff)
fixed wrong condition in libsmbios checks
Fixed wrong conditions for version check of libsmbios, introduced with commit 1852641290ec7c0f75e85ba8ef794c0e74923677.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 87cd2852..f7d235da 100644
--- a/configure.in
+++ b/configure.in
@@ -419,7 +419,7 @@ if test "x$use_smbios" = "xyes" ; then
if ( sscanf( LIBSMBIOS_RELEASE_VERSION , "%d.%d.%d", &major, &minor, &micro ) == 3 ) {
if ((major == 0 && minor == 13 && micro >= 4) ||
(major == 0 && minor > 13) ||
- (major >= 0)) {
+ (major > 0)) {
return 0;
}
}
@@ -444,7 +444,7 @@ if test "x$use_smbios" = "xyes" ; then
if ( sscanf( LIBSMBIOS_RELEASE_VERSION , "%d.%d.%d", &major, &minor, &micro ) == 3 ) {
if ((major == 2 && minor == 0 && micro >= 3) ||
(major == 2 && minor > 0) ||
- (major >= 2)) {
+ (major > 2)) {
return 0;
}
}