summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2007-06-05 17:04:11 +0100
committerRichard Hughes <richard@hughsie.com>2007-06-05 17:04:11 +0100
commit8670a01517bb33d046cfb6416de13c411e6a3f6c (patch)
tree566e59f63570cc711988310e22c27932e9875d3b /configure.in
parent21edb06bbf0e24a1c1c9948c2a8e73b58ebbb516 (diff)
add keymap capabilities into hal
Add keymapping infrastructure into hal so we can remap scancode->keycodes at boot time, fixing many multimedia keyboards. Thanks to everybody who helped review this.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b2adc77c..cd8c80c2 100644
--- a/configure.in
+++ b/configure.in
@@ -470,6 +470,21 @@ if test "x$enable_console_kit" != "xno"; then
msg_conkit=yes
fi
+AC_ARG_WITH([keymaps], AS_HELP_STRING([--with-keymaps], [Re-map multimedia keys (auto)]))
+BUILD_KEYMAPS=no
+if test "x$with_keymaps" = "xyes" ; then
+ BUILD_KEYMAPS=yes
+elif test "x$with_keymaps" = "x" ; then
+ case "${HALD_BACKEND}" in
+ linux)
+ BUILD_KEYMAPS=yes
+ ;;
+ *)
+ ;;
+ esac
+fi
+AM_CONDITIONAL(BUILD_KEYMAPS, [test x$BUILD_KEYMAPS = xyes])
+
# check for PolicyKit
AM_CONDITIONAL(HAVE_POLKIT, [false])
AC_ARG_ENABLE([policy-kit],
@@ -989,6 +1004,7 @@ echo "
Macbook Pro utils: ${BUILD_MACBOOKPRO} (Linux only, x86 only, requires libpci)
OMAP utils: ${BUILD_OMAP} (Linux only, arm only)
CPU frequency scaling: ${BUILD_CPUFREQ} (Linux only)
+ Re-map multimedia keys: ${BUILD_KEYMAPS} (Linux only)
Forward IBM ACPI events: ${BUILD_ACPI_IBM} (Linux only)
Forward Toshiba ACPI events: ${BUILD_ACPI_TOSHIBA} (Linux only)
USB wireless mouse power: ${BUILD_USBCSR} (Linux only, requires libusb)