summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHolger Freyther <zecke@openmoko.org>2008-10-27 13:04:02 +0100
committerDanny Kukawka <danny.kukawka@web.de>2008-10-27 13:04:02 +0100
commit736082b1945dd835d43c7d767d857d4e8bd68389 (patch)
treedf13f7701c3615cd16a59ccae1c9f254d8874d3c /configure.in
parent4fc860155b36d7767222ed92e640c07fd4a92019 (diff)
allow to cross compile hal with host and target having different input.h
Allow to cross compile hal with host and target having different input.h. When the Makefile is picking /usr/include/linux/input.h and libc kernel headers are newer than the one for target I will get a nice compile error that the new keynames are not known. The attached patch allows to inform hal where my input.h resides and allows to cross compile it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 68f75f54..d4f8669d 100644
--- a/configure.in
+++ b/configure.in
@@ -1021,6 +1021,11 @@ AC_ARG_WITH([linux-input-header],
[Use an given Linux input.h rather than that installed on the system (<linux/input.h>)]))
if test "x$with_linux_input_header" != "x"; then
AC_DEFINE_UNQUOTED(HAL_LINUX_INPUT_HEADER_H, "$with_linux_input_header", [If set, the header to use instead of <linux/input.h>])
+ LINUX_INPUT_H=$with_linux_input_header
+ AC_SUBST(LINUX_INPUT_H)
+else
+ LINUX_INPUT_H=/usr/include/linux/input.h
+ AC_SUBST(LINUX_INPUT_H)
fi
dnl