summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-18 12:48:09 -0400
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-08-18 12:48:09 -0400
commit64c6ff319640e2420a533ca40d8f2b0622c4b0b0 (patch)
tree6fdb9d0216237ef4419760e9e68a707303fe0532 /configure.in
parent195146f263e193dc80a4094b4750999657734243 (diff)
re-enable libvolume_id support for FreeBSD
FreeBSD's backend still requires libvolume_id. Add it back until a better solution can be found.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2e947a7a..890bba3e 100644
--- a/configure.in
+++ b/configure.in
@@ -15,6 +15,7 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
glib_module="glib-2.0 >= 2.10.0 gobject-2.0 > 2.10.0 dbus-glib-1 >= 0.61"
dbus_module="dbus-1 >= 0.61"
blkid_module="blkid >= 2.15"
+volume_id_module="libvolume_id >= 0.77"
polkit_module="polkit >= 0.5"
# libtool versioning - this applies to libhal and libhal-storage
@@ -686,8 +687,20 @@ else
fi
AC_MSG_RESULT($have_glib_2_14)
+case "$host" in
+ *-*-freebsd*)
+ PKG_CHECK_MODULES(VOLUME_ID, [$volume_id_module])
+ AC_SUBST(VOLUME_ID_CFLAGS)
+ AC_SUBST(VOLUME_ID_LIBS)
+ ;;
+ *)
+ ;;
+esac
+
# blkid (util-linux-ng)
case "$host" in
+*-*-freebsd*)
+ ;;
*-*-solaris*)
;;
*)