summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRob Taylor <rob.taylor@codethink.co.uk>2007-11-26 17:09:11 +0000
committerRob Taylor <rob.taylor@codethink.co.uk>2007-11-26 17:09:11 +0000
commit3ede34abd7a074cf0b054772c60dd3095989e924 (patch)
tree230be86bec18f1bedf8bcf03819553d2859e62c3 /configure.in
parent6aa022d4e38302056beeafbd67a6af433822a9bc (diff)
add --with-linux-input-header configure switch
This adds a --with-linux-input-header configure switch to allow the use of a local copy of the latest input.h without having it available in include search paths.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fc5a6916..90f10f36 100644
--- a/configure.in
+++ b/configure.in
@@ -919,6 +919,14 @@ fi
msg_sonypic=$have_sonypic
AM_CONDITIONAL(HAVE_SONYPIC, [test x$msg_sonypic = xyes], [Compiling Sony PIC])
+dnl use non-system input.h
+AC_ARG_WITH([linux-input-header],
+ AS_HELP_STRING([--with-linux-input-header=<path>],
+ [Use an given Linux input.h rather than that installed on the system (<linux/input.h>)]))
+if test "x$with_linux_input_header" != "x"; then
+ AC_DEFINE_UNQUOTED(HAL_LINUX_INPUT_HEADER_H, "$with_linux_input_header", [If set, the header to use instead of <linux/input.h>])
+fi
+
dnl
dnl SUBSETTING END
dnl