summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael E Brown <Michael_E_Brown@dell.com>2007-11-15 21:35:26 +0100
committerDanny Kukawka <danny.kukawka@web.de>2007-11-15 21:35:26 +0100
commit1852641290ec7c0f75e85ba8ef794c0e74923677 (patch)
treeed6fcde75908c22f37bab93c67644c88b7c74950 /configure.in
parent534735f7844300fec22cfebcf515ca46c9b91879 (diff)
fix version check code for libmsbios in configure.in
This patch fixes the version check for libsmbios. It currently fails if the major bumps (which I am planning to do shortly).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d2b273ff..fc5a6916 100644
--- a/configure.in
+++ b/configure.in
@@ -405,7 +405,8 @@ if test "$LIB_SMBIOS" = "yes" ; then
if ( sscanf( LIBSMBIOS_RELEASE_VERSION , "%d.%d.%d", &major, &minor, &micro ) == 3 ) {
if ((major == 0 && minor == 13 && micro >= 4) ||
- (major >= 0 && minor > 13)) {
+ (major == 0 && minor > 13) ||
+ (major >= 0)) {
return 0;
}
}