summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2013-03-08 17:29:08 +0100
committerKay Sievers <kay@vrfy.org>2013-03-08 17:29:08 +0100
commit6f8e403dc2b567816161e736255067c71a1a84db (patch)
tree215c0199bec5418990cc43daea1cb27b3d325a44 /Makefile.am
parent00593f51c0d0f79b335169899f6c8fe43456b9e2 (diff)
build-sys: use $XSLTPROC and enforce "unresolved symbols" check
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a9342c..df8e06d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,7 @@ gummiboot_LDADD = \
$(BLKID_LIBS)
%.8: %.xml
- $(AM_V_GEN)xsltproc -o $@ --nonet \
+ $(AM_V_GEN)$(XSLTPROC) -o $@ --nonet \
--stringparam man.output.quietly 1 \
--stringparam man.th.extra1.suppress 1 \
--stringparam man.authors.section.enabled 0 \
@@ -117,6 +117,7 @@ $(efi_solib): $(efi_objects)
$(AM_V_CCLD)$(LD) $(efi_ldflags) $(efi_objects) \
-o $@ -lefi -lgnuefi $(shell $(CC) -print-libgcc-file-name); \
nm -D -u $@ | grep ' U ' && exit 1 || :
+.DELETE_ON_ERROR: $(efi_solib)
$(efi_loadername): $(efi_solib)
$(AM_V_GEN) objcopy -j .text -j .sdata -j .data -j .dynamic \