summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <kiagiadakis.george@gmail.com>2010-07-17 15:38:15 +0300
committerGeorge Kiagiadakis <kiagiadakis.george@gmail.com>2010-07-17 15:38:15 +0300
commit6a0ed64bedc24c942abeac8ff584c7571ece9999 (patch)
treede74dcc7e64a1ce646f299736e113f312678e772 /CMakeLists.txt
parent9cb5e35c5b1c2fb4a06bb6661e37a8a53326b144 (diff)
Add cmake target to generate API docs and write some basic API docs where needed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4053086..eb74eb1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,8 @@ enable_testing()
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
set(BUILDING_QTGSTREAMER TRUE)
+set(QTGSTREAMER_VERSION 0.1)
+set(QTGSTREAMER_SOVERSION 0)
find_package(Qt4 COMPONENTS QtCore QtTest REQUIRED)
find_package(QtGstreamer REQUIRED)
@@ -29,3 +31,6 @@ add_subdirectory(examples)
# Add uninstall target. Taken from the KDE4 scripts
configure_file("${CMAKE_SOURCE_DIR}/cmake/modules/cmake_uninstall.cmake.in" "${CMAKE_BINARY_DIR}/cmake_uninstall.cmake" @ONLY)
add_custom_target(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_BINARY_DIR}/cmake_uninstall.cmake")
+
+# Add doc target
+include(UseDoxygen)