summaryrefslogtreecommitdiff
path: root/tests/examples/meson.build
diff options
context:
space:
mode:
authorU. Artie Eoff <ullysses.a.eoff@intel.com>2019-10-08 12:19:06 -0700
committerU. Artie Eoff <ullysses.a.eoff@intel.com>2019-10-16 12:48:24 -0700
commit97aabe8784c057a4bee33d6f541ab7d75ca3708e (patch)
treeba1cf34ee77bd61bc9bf8844379302fb0d609ebe /tests/examples/meson.build
parent8af5ef8a0be0e5a6d97b6f8e9c942331d065e30a (diff)
tests: move examples and tests to subfolders
This makes way for adding unit (check) tests.
Diffstat (limited to 'tests/examples/meson.build')
-rw-r--r--tests/examples/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/examples/meson.build b/tests/examples/meson.build
new file mode 100644
index 00000000..0a61f7d0
--- /dev/null
+++ b/tests/examples/meson.build
@@ -0,0 +1,28 @@
+examples = [
+ 'test-vaapisink',
+ 'test-vaapipostproc',
+ 'test-roi',
+]
+
+foreach example : examples
+ executable(example, '@0@.c'.format(example),
+ c_args : gstreamer_vaapi_args,
+ include_directories: [configinc, libsinc],
+ dependencies : [gst_dep, gstvideo_dep],
+ install: false)
+endforeach
+
+if USE_X11
+if gtk_dep.found()
+ executable('test-vaapicontext', 'test-vaapicontext.c',
+ c_args : gstreamer_vaapi_args,
+ include_directories: [configinc, libsinc],
+ dependencies : [ gst_dep,
+ gstvideo_dep,
+ libva_dep,
+ x11_dep,
+ gtk_dep,
+ libva_x11_dep ],
+ install: false)
+endif
+endif