summaryrefslogtreecommitdiff
path: root/ges/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@osg.samsung.com>2017-08-29 15:25:18 -0300
committerThibault Saunier <thibault.saunier@osg.samsung.com>2017-08-29 22:20:46 -0300
commit893169175d1e0e69c0fe511975cc5b73ffd55cbd (patch)
tree14cd8fc103221ef73eae25db6a2c971cc84a08b3 /ges/meson.build
parent473e2f633b8d20007ae245ae23b79ff894311735 (diff)
Generate bindings for GES if avalaible
Diffstat (limited to 'ges/meson.build')
-rw-r--r--ges/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/ges/meson.build b/ges/meson.build
new file mode 100644
index 0000000..b077d44
--- /dev/null
+++ b/ges/meson.build
@@ -0,0 +1,39 @@
+pkg = 'gst-editing-services'
+raw_api_fname = join_paths(meson.current_source_dir(), pkg + '-api.raw')
+metadata_fname = join_paths(meson.current_source_dir(), pkg + '.metadata')
+snk = join_paths(meson.current_source_dir(), '../', meson.project_name() + '.snk')
+
+glueincludes = 'ges/ges.h'
+gluefile = join_paths(meson.current_build_dir(), 'generate.c')
+
+sources = [
+ 't.cs'
+]
+
+subdir('generated')
+
+# Install with gacutil_install.py from gtk-sharp.
+ges_sharp = library(pkg + '-sharp', source_gen, sources,
+ cs_args: ['-nowarn:169', '-nowarn:108', '-nowarn:114', '-unsafe',
+ '-keyfile:' + snk],
+ link_with: gst_sharp,
+ dependencies: [glib_sharp_dep, gio_sharp_dep])
+
+gluegen = custom_target(pkg + 'gluegen',
+ input: raw_api_fname,
+ output: 'generate.c',
+ command: [generate_api, '--fakeglue'],
+ depends: [source_gen])
+
+library('gessharpglue-1.0.0', gluegen, dependencies: gst_deps + [ges_dep])
+
+ges_sharp_dep = declare_dependency(dependencies: [glib_sharp_dep, gio_sharp_dep, gst_sharp_dep,
+ ges_dep], link_with: ges_sharp)
+meson.add_install_script(gacutil_install, meson.project_name(), gst_sharp.full_path())
+
+configure_file(
+ input: pkg + '-sharp.dll.config',
+ output: pkg + '-sharp.dll.config',
+ configuration: configuration_data())
+
+