summaryrefslogtreecommitdiff
path: root/sys/v4l2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/v4l2/Makefile.am')
-rw-r--r--sys/v4l2/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/sys/v4l2/Makefile.am b/sys/v4l2/Makefile.am
index 4330da6e1..6b5134fca 100644
--- a/sys/v4l2/Makefile.am
+++ b/sys/v4l2/Makefile.am
@@ -8,7 +8,6 @@ xv_source =
xv_libs =
endif
-
# variables used for enum/marshal generation
glib_enum_headers = tuner.h tunernorm.h tunerchannel.h
glib_enum_define = GST_INTERFACES
@@ -56,11 +55,10 @@ libgstvideo4linux2_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) \
libgstvideo4linux2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstvideo4linux2_la_LIBTOOLFLAGS = --tag=disable-static
-
libgstvideo4linux2_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
- $(GST_BASE_LIBS) \
- $(GST_PLUGINS_BASE_LIBS) \
+ -lgstallocators-$(GST_API_VERSION) \
-lgstvideo-$(GST_API_VERSION) \
+ $(GST_BASE_LIBS) \
$(GST_LIBS) \
$(xv_libs) \
$(LIBV4L2_LIBS) \