summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2355654..3313375 100644
--- a/configure.in
+++ b/configure.in
@@ -196,6 +196,26 @@ fi
AC_SUBST(AGL_CFLAGS)
AC_SUBST(AGL_LIBS)
+
+dnl ===========================================================================
+
+AC_ARG_ENABLE(egl,
+ AC_HELP_STRING([--enable-egl], [Enable glitz's EGL backend]),
+ [use_egl=$enableval], [use_egl=no])
+
+EGL_LIBS="-lGL"
+EGL_CFLAGS="$EGL_CFLAGS"
+
+if test "x$use_egl" = "xyes"; then
+ AM_CONDITIONAL(GLITZ_BUILD_EGL_BACKEND, true)
+else
+ AM_CONDITIONAL(GLITZ_BUILD_EGL_BACKEND, false)
+fi
+
+AC_SUBST(EGL_CFLAGS)
+AC_SUBST(EGL_LIBS)
+
+
dnl ===========================================================================
AC_OUTPUT([
@@ -203,9 +223,11 @@ Makefile
src/Makefile
src/glx/Makefile
src/agl/Makefile
+src/egl/Makefile
src/glitz.pc
src/glx/glitz-glx.pc
src/agl/glitz-agl.pc
+src/egl/glitz-egl.pc
])
dnl ===========================================================================
@@ -214,4 +236,5 @@ echo ""
echo "glitz will be compiled with the following backends:"
echo " GLX: $use_glx"
echo " AGL: $use_agl"
+echo " EGL: $use_egl"
echo ""