summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Reveman <davidr@novell.com>2004-11-03 22:50:58 +0000
committerDavid Reveman <davidr@novell.com>2004-11-03 22:50:58 +0000
commit019e7f7e630ce6faeedeb1cf0b9a340530790101 (patch)
treebd05c27a379cd29d13a7b66e572279fb49ecacfa /configure.in
parent0ef062afaa57e370ac68b26d11f4cd60f2b0388b (diff)
Source tree restructuring and switch to new drawable interface
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d539bbc..795c480 100644
--- a/configure.in
+++ b/configure.in
@@ -6,7 +6,7 @@ dnl ===========================================================================
# Package version number, (as distinct from shared library version)
# This must be manually synchronized with the version in src/glitz.h
-GLITZ_VERSION=0.2.3
+GLITZ_VERSION=0.3.0
# libtool shared library version
# Increment if the interface has additions, changes, removals.
@@ -93,6 +93,14 @@ AC_C_BIGENDIAN
dnl ===========================================================================
+GLITZ_LIB='-L$(top_builddir)/src -lglitz'
+GLITZ_INC='-I$(top_builddir)/src -I$(top_srcdir)/src'
+
+AC_SUBST(GLITZ_LIB)
+AC_SUBST(GLITZ_INC)
+
+dnl ===========================================================================
+
AC_ARG_ENABLE(glx,
AC_HELP_STRING([--disable-glx], [Disable glitz's GLX backend]),
[use_glx=$enableval], [use_glx=yes])
@@ -193,9 +201,11 @@ dnl ===========================================================================
AC_OUTPUT([
Makefile
src/Makefile
-glitz.pc
-glitz-glx.pc
-glitz-agl.pc
+src/glx/Makefile
+src/agl/Makefile
+src/glitz.pc
+src/glx/glitz-glx.pc
+src/agl/glitz-agl.pc
])
dnl ===========================================================================