summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2003-03-22 21:25:34 +0000
committerTor Lillqvist <tml@iki.fi>2003-03-22 21:25:34 +0000
commitdaeed6e048a413a94754fd79f62307ca9be80a43 (patch)
treeb123ff489671ab4e1a71b7c09b6fa11bb9c135de /Makefile.am
parentcc9dd09816f717fc678d097a69f793dca1b1eef0 (diff)
Changes for Windows:
On Windows with gcc (a.k.a. mingw) build as a DLL. We don't want to hardcode the fonts.conf file location in the DLL, so we look up the DLL location at run-time in a DllMain() function. The fonts.conf location is deduced from that. The colon can't be used as path separator on Windows, semicolon is used instead. File path components can be separated with either slash or backslash. Absolute paths can also begin with a drive letter. Add internal function FcStrLastSlash that strrchr's the last slash, or backslash on Windows. There is no link() on Windows. For atomicity checks, mkdir a lock directory instead. In addition to HOME, also look for USERPROFILE. Recognize the special font directory token WINDOWSFONTDIR, to use the system's font directory. Remove the fontconfig-def.cpp that was obsolete. Add fontconfig.def(.in), without internal functions. Add a fontconfig-zip(.in) script, used to build a binary distribution.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ee600e..6c3b041 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,8 @@ EXTRA_DIST = \
fonts.dtd \
local.conf \
fontconfig.spec.in \
- fontconfig.spec
+ fontconfig.spec \
+ fontconfig-zip.in
pkgconfigdir=$(libdir)/pkgconfig
pkgconfig_DATA = fontconfig.pc