summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRyan Schmidt <git@ryandesign.com>2021-07-08 16:09:19 -0500
committerRyan Schmidt <git@ryandesign.com>2021-07-08 16:09:19 -0500
commit8f56421e5fc4eff1142a6294b22a06a8de9b7a40 (patch)
tree1a6fc132725c4ceb3f5847ea0f1df2584620502b /Makefile.am
parent4d43f84188847a6a77f7259f986fb178c52c1ea7 (diff)
Avoid PCRE syntax when using grep
Avoid PCRE syntax when using grep because some versions of grep don't support that.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e10b710..1ef3669 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -174,7 +174,7 @@ debuild-dirs: distdir
DISTCHECK_CONFIGURE_FLAGS =
check-versions:
- @$(GREP) -e '^\s*version\s*:\s*.'$(VERSION)'.,' $(srcdir)/meson.build >/dev/null || { \
+ @$(GREP) -e "^[[:space:]]*version[[:space:]]*:[[:space:]]*'$(VERSION)'," $(srcdir)/meson.build >/dev/null || { \
echo "======================================================================================"; \
echo "Meson version does not seem to match autotools version $(VERSION), update meson.build!"; \
echo "======================================================================================"; \