summaryrefslogtreecommitdiff
path: root/samples/build/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'samples/build/cmake/CMakeLists.txt')
-rw-r--r--samples/build/cmake/CMakeLists.txt50
1 files changed, 25 insertions, 25 deletions
diff --git a/samples/build/cmake/CMakeLists.txt b/samples/build/cmake/CMakeLists.txt
index 89f783b..f9da24c 100644
--- a/samples/build/cmake/CMakeLists.txt
+++ b/samples/build/cmake/CMakeLists.txt
@@ -1,25 +1,25 @@
-# =================================================================================================
-# ADOBE SYSTEMS INCORPORATED
-# Copyright 2013 Adobe Systems Incorporated
-# All Rights Reserved
-#
-# NOTICE: Adobe permits you to use, modify, and distribute this file in accordance with the terms
-# of the Adobe license agreement accompanying it.
-# =================================================================================================
-
-# define minimum cmake version
-cmake_minimum_required(VERSION 2.8.6)
-#This projects relative path to XMP Root
-set ( XMP_THIS_PROJECT_RELATIVEPATH "../../../")
-#setting the root for XMP SDK
-if(NOT DEFINED XMP_ROOT)
- set(XMP_ROOT ${CMAKE_CURRENT_SOURCE_DIR}/${XMP_THIS_PROJECT_RELATIVEPATH})
-endif()
-
-if(NOT DEFINED COMMON_BUILD_SHARED_DIR)
- set(COMMON_BUILD_SHARED_DIR ${XMP_ROOT}/build/shared)
-endif()
-
-set(USE_BUILDMODE_LIBNAME 0)
-
-include(CMakeListsCommon.txt) \ No newline at end of file
+# =================================================================================================
+# ADOBE SYSTEMS INCORPORATED
+# Copyright 2013 Adobe Systems Incorporated
+# All Rights Reserved
+#
+# NOTICE: Adobe permits you to use, modify, and distribute this file in accordance with the terms
+# of the Adobe license agreement accompanying it.
+# =================================================================================================
+
+# define minimum cmake version
+cmake_minimum_required(VERSION 3.5.2)
+#This projects relative path to XMP Root
+set ( XMP_THIS_PROJECT_RELATIVEPATH "../../../")
+#setting the root for XMP SDK
+if(NOT DEFINED XMP_ROOT)
+ set(XMP_ROOT ${CMAKE_CURRENT_SOURCE_DIR}/${XMP_THIS_PROJECT_RELATIVEPATH})
+endif()
+
+if(NOT DEFINED COMMON_BUILD_SHARED_DIR)
+ set(COMMON_BUILD_SHARED_DIR ${XMP_ROOT}/build/shared)
+endif()
+
+set(USE_BUILDMODE_LIBNAME 0)
+
+include(CMakeListsCommonSDK.txt) \ No newline at end of file