summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorHenrik Rydberg <rydberg@bitmath.org>2011-01-05 11:19:44 +0100
committerHenrik Rydberg <rydberg@bitmath.org>2011-01-05 11:19:44 +0100
commit126262395e77b9de22e2cb7f1af15604a237118f (patch)
tree4dbc656fb127dff1840a95fb1e0973a5206e47cc /tools/Makefile.am
parent1b8094e175138f7caaa1b8ed4676373fe2abe4e0 (diff)
Add man-pages for the various evemu-tools.
Using asciidoc and xmlto, conditional on their availability at configure time. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Henrik Rydberg <rydberg@euromail.se>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index e845fb2..ca86c07 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -10,3 +10,26 @@ bin_PROGRAMS = \
INCLUDES=-I$(top_srcdir)/include/
AM_LDFLAGS = $(top_builddir)/src/libutouch-evemu.la
+
+
+# man page generation
+if HAVE_DOCTOOLS
+# actual man pages
+man_pages_sources = evemu-describe.txt evemu-device.txt
+# shadow man pages
+man_pages_shadows = evemu-record.1 evemu-play.1
+
+man_pages = $(man_pages_sources:.txt=.1) $(man_pages_shadows)
+
+SUFFIXES = .1 .txt .xml
+
+.xml.1:
+ @$(XMLTO) man $<
+
+.txt.xml:
+ @$(ASCIIDOC) -b docbook -d manpage -o $@ $<
+
+dist_man_MANS = $(man_pages)
+CLEANFILES = $(dist_man_MANS)
+MAINTAINERCLEANFILES = $(man_pages) *.xml
+endif