summaryrefslogtreecommitdiff
path: root/intel/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'intel/meson.build')
-rw-r--r--intel/meson.build22
1 files changed, 8 insertions, 14 deletions
diff --git a/intel/meson.build b/intel/meson.build
index 3d6bbac6..355bf35d 100644
--- a/intel/meson.build
+++ b/intel/meson.build
@@ -64,43 +64,37 @@ test_decode = executable(
test(
'gen4-3d.batch',
- prog_bash,
- args : files('tests/gen4-3d.batch.sh'),
+ find_program('tests/gen4-3d.batch.sh'),
workdir : meson.current_build_dir(),
)
test(
'gen45-3d.batch',
- prog_bash,
- args : files('tests/gm45-3d.batch.sh'),
+ find_program('tests/gm45-3d.batch.sh'),
workdir : meson.current_build_dir(),
)
test(
'gen5-3d.batch',
- prog_bash,
- args : files('tests/gen5-3d.batch.sh'),
+ find_program('tests/gen5-3d.batch.sh'),
workdir : meson.current_build_dir(),
)
test(
'gen6-3d.batch',
- prog_bash,
- args : files('tests/gen6-3d.batch.sh'),
+ find_program('tests/gen6-3d.batch.sh'),
workdir : meson.current_build_dir(),
)
test(
'gen7-3d.batch',
- prog_bash,
- args : files('tests/gen7-3d.batch.sh'),
+ find_program('tests/gen7-3d.batch.sh'),
workdir : meson.current_build_dir(),
)
test(
'gen7-2d-copy.batch',
- prog_bash,
- args : files('tests/gen7-2d-copy.batch.sh'),
+ find_program('tests/gen7-2d-copy.batch.sh'),
workdir : meson.current_build_dir(),
)
test(
'intel-symbol-check',
- prog_bash,
+ find_program('intel-symbol-check'),
env : env_test,
- args : [files('intel-symbol-check'), libdrm_intel]
+ args : libdrm_intel,
)