summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMichel Dänzer <michel@tungstengraphics.com>2007-09-07 20:17:49 +0200
committerMichel Dänzer <michel@tungstengraphics.com>2007-09-07 20:17:49 +0200
commitb257bbe48a0851d27150d21cd124af2dc3e53385 (patch)
treec230ae915264a7249a23c0f858265cfe12622554 /tests/Makefile.am
parentcbf7c5cace00d23f6b694977aa058026b9d39e9f (diff)
parent06bb07259531d10df2c1979919af899e3812057b (diff)
Merge remote branch 'upstream/master' into i915-zone-renderingi915-zone-rendering
Conflicts: linux-core/drm_bo.c linux-core/drm_objects.h linux-core/i915_buffer.c shared-core/i915_dma.c shared-core/i915_drm.h shared-core/i915_drv.h shared-core/i915_irq.c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..dce1754e
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,29 @@
+AM_CFLAGS = \
+ -I $(top_srcdir)/shared-core \
+ -I $(top_srcdir)/libdrm
+
+noinst_PROGRAMS = \
+ dristat \
+ drmstat
+
+EXTRA_LTLIBRARIES = libdrmtest.la
+libdrmtest_la_SOURCES = \
+ drmtest.c \
+ drmtest.h
+libdrmtest_la_LIBADD = \
+ $(top_builddir)/libdrm/libdrm.la
+
+LDADD = libdrmtest.la
+
+TESTS = auth \
+ openclose \
+ getversion \
+ getclient \
+ getstats \
+ lock \
+ setversion \
+ updatedraw
+
+EXTRA_PROGRAMS = $(TESTS)
+CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES)
+