summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@gnome.org>2007-07-12 10:22:36 -0500
committerJonathon Jongsma <jjongsma@gnome.org>2007-07-12 10:22:36 -0500
commit76f5ca4d67e0455c24c69d80562f5854ad7522c1 (patch)
tree581e4e0ded34271698f240ee08852055fda84c4c /Makefile.am
parent9bd228fc5d0b73dcc261aa9f40bf94bc02f42576 (diff)
Push docs and a doc-tarball to the web on releasev1.4.0
* Makefile.am: add doc-publish target and make release-publish depend on this. This automatically uploads the new API documentation on release * docs/reference/Makefile.am: upload the html documentation and a tarball of the documentation to the cairographics.org site
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 223e6e9..8d5ce0e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -77,7 +77,10 @@ release-upload: release-check $(tar_file) $(sha1_file) $(gpg_file)
ssh $(RELEASE_UPLOAD_HOST) "rm -f $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-[0-9]* && ln -s $(tar_file) $(RELEASE_UPLOAD_DIR)/LATEST-$(PACKAGE)-$(VERSION)"
$(GIT) tag -s -m "$(PACKAGE) release $(VERSION)" v$(VERSION)
-release-publish: release-upload releases/$(sha1_file)
+doc-publish:
+ (cd docs/reference && $(MAKE) $(AM_MAKEFLAGS) publish)
+
+release-publish: release-upload doc-publish releases/$(sha1_file)
@echo ""
@echo "Please send an announcement to $(RELEASE_ANNOUNCE_LIST)"
@echo "including the following:"