summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2020-04-30 16:03:03 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2020-04-30 16:15:01 +0200
commit365e61968f188ae5e63d8e54f1b1bd59346525da (patch)
tree08e7a41306b2e1283e45a768d3b280b8bdaa82a1 /Makefile.am
parente3f94cfc3cbc25c13cd87b5921811823fcc7ae99 (diff)
Add support for building cairomm with Meson
cairomm can be built with either Autotools or Meson. See MR !2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ff0de26..0f50ed5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,20 @@ dist_noinst_SCRIPTS = autogen.sh
DISTCLEANFILES = MSVC_NMake/cairomm/cairommconfig.h
+# Distribute files needed when building cairomm with Meson.
+EXTRA_DIST = \
+ meson.build \
+ meson_options.txt \
+ cairommconfig.h.meson \
+ MSVC_NMake/cairomm/meson.build \
+ MSVC_NMake/gendef/meson.build \
+ cairomm/meson.build \
+ data/meson.build \
+ docs/reference/meson.build \
+ examples/meson.build \
+ tests/meson.build \
+ untracked/README
+
# Optional: auto-generate the ChangeLog file from the git log on make dist
include $(top_srcdir)/build/dist-changelog.am