summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJunyan He <junyan.he@linux.intel.com>2015-11-12 14:07:55 +0800
committerYang Rong <rong.r.yang@intel.com>2015-11-17 11:43:50 +0800
commitb43f4df25752bf9b4b690aa27fe2bea622ce9b38 (patch)
tree3cf8aa554866ed98b9403cd7a441cc99139aa2e8 /src/CMakeLists.txt
parent804bf86528eb80abd76c1e7af4cfdc79fb49a53d (diff)
CMake: Add -lrt to the link command of libcl.so
The clock_gettime will cause the linkage error on some version of GCC, we need to add -lrt at the end of the link command line. Signed-off-by: Junyan He <junyan.he@linux.intel.com> Reviewed-by: "Yang, Rong R" <rong.r.yang@intel.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c917e76d..4c5112c8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -144,6 +144,7 @@ add_library(cl SHARED ${OPENCL_SRC})
ADD_DEPENDENCIES(cl ${GIT_SHA1})
target_link_libraries(
cl
+ rt
${X11_LIBRARIES}
${XEXT_LIBRARIES}
${XFIXES_LIBRARIES}