summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbsegovia <segovia.benjamin@gmail.com>2012-08-13 16:17:43 +0000
committerbsegovia <segovia.benjamin@gmail.com>2012-08-13 16:17:43 +0000
commit1d8eaa446ae23f27421ece63af0fa1c990c035fa (patch)
tree37ea390d1ec2388d4042461c7dfa34445e57424a /CMakeLists.txt
parent4ecc6e9d8b0397e2c5e29a8bfbe3026e21df0679 (diff)
Reenabled the CMake build path. It is really imperfect and the build CMake
scripts should be cleanly unified later
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5685cee9..ea840719 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,9 @@ ENDIF (USE_FULSIM)
SET(CMAKE_CXX_FLAGS "-Wall -Wno-invalid-offsetof -mfpmath=sse --no-rtti -Wcast-align -std=c++0x")
SET(CMAKE_C_FLAGS "-Wall -mfpmath=sse -msse2 -Wcast-align")
+# Front end stuff we need
+Find_Package(LLVM REQUIRED)
+
# XLib
INCLUDE(CMake/FindXLib.cmake)
IF(XLIB_FOUND)
@@ -95,7 +98,7 @@ ELSE(GBE_FOUND)
MESSAGE(STATUS "Looking for Gen-Backend - not found")
ENDIF(GBE_FOUND)
-# the run-time itself
+ADD_SUBDIRECTORY(backend)
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(utests)