summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@intel.com>2013-11-27 10:01:56 +0800
committerZhigang Gong <zhigang.gong@intel.com>2013-11-27 16:25:45 +0800
commitf1065c8e0d694b622d1030870059a22d3f5ab8e3 (patch)
tree9f5127fc2f6b07d66f132205ed9e2e2843ea56db /CMakeLists.txt
parent011a01321ee7a2060c0b5e18e940068ad6ddb388 (diff)
Fix a build problem when the llvm version has the fix version digit.
If the llvm version is something like 3.3.1, the previous cmake script will generate an incorrect cflags as: -DLLVM_33 1 which breaks the build. This commit also update the stable llvm version from 3.1 to 3.3. Signed-off-by: Zhigang Gong <zhigang.gong@intel.com> Reviewed-by: Yang Rong <rong.r.yang@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ec6c08..b44e7a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,7 @@ SET(CMAKE_C_FLAGS "-Wall -mfpmath=sse -msse2 -Wcast-align -msse2 -msse3 -mssse3
# Front end stuff we need
#INCLUDE(CMake/FindLLVM.cmake)
-Find_Package(LLVM 3.1)
+Find_Package(LLVM 3.3)
# XLib
Find_Package(X11)