summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@linux.intel.com>2012-12-11 14:29:10 +0800
committerZhigang Gong <zhigang.gong@linux.intel.com>2013-03-29 19:35:17 +0800
commitcb61937e57fde3ac3a4e5aed0a04ffc730efdc00 (patch)
treea4bb16f987e5b7bdd2309755c1aec21a9559ce43 /CMakeLists.txt
parent5fa7a3db9189f19ed5af4f00f83fa61a62a3a17e (diff)
CMake fixup.
Add a FindLLVM to handle the llvm package finding function. Fixed the broken CMake files in backend. Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea84071..41307e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,11 +44,11 @@ ELSE (USE_FULSIM)
ADD_DEFINITIONS(-DUSE_FULSIM=0)
ENDIF (USE_FULSIM)
-SET(CMAKE_CXX_FLAGS "-Wall -Wno-invalid-offsetof -mfpmath=sse --no-rtti -Wcast-align -std=c++0x")
-SET(CMAKE_C_FLAGS "-Wall -mfpmath=sse -msse2 -Wcast-align")
+SET(CMAKE_CXX_FLAGS "-Wall -Wno-invalid-offsetof -mfpmath=sse --no-rtti -Wcast-align -std=c++0x -msse2 -msse3 -mssse3 -msse4.1 ")
+SET(CMAKE_C_FLAGS "-Wall -mfpmath=sse -msse2 -Wcast-align -msse2 -msse3 -mssse3 -msse4.1 ")
# Front end stuff we need
-Find_Package(LLVM REQUIRED)
+INCLUDE(CMake/FindLLVM.cmake)
# XLib
INCLUDE(CMake/FindXLib.cmake)
@@ -66,6 +66,10 @@ ELSE(DRM_FOUND)
MESSAGE(STATUS "Looking for DRM - not found")
ENDIF(DRM_FOUND)
+# OpenGL
+find_package(OpenGL)
+# Threads
+find_package(Threads)
# DRM Intel
INCLUDE(CMake/FindDRMIntel.cmake)
IF(DRM_INTEL_FOUND)