summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOlli Salli <ollisal@gmail.com>2011-04-25 15:47:22 +0300
committerOlli Salli <ollisal@gmail.com>2011-04-25 16:54:05 +0300
commit18f6cc2e4c1dc203270043fd0de77619808aa9db (patch)
treef620b4f6964307f494574f61f5f22657c965355f /CMakeLists.txt
parent53876bd4000c5e1375d9abbcb84ed1d3f4d592a9 (diff)
Remove QDBusServiceWatcher feature check
Redundant as we depend on Qt 4.6 nowadays.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a050be90..550fcd86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,21 +124,6 @@ macro_log_feature(QT4_GLIB_SUPPORT "Qt4 Glib Support"
"http://qt.nokia.com/" FALSE ""
"Needed, together with Telepathy-Glib, to build most of the unit tests")
-SET(CMAKE_REQUIRED_LIBRARIES ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY})
-
-# Check for QDBusServiceWatcher being present
-# This check can be safely removed if we start depending on Qt 4.6
-CHECK_CXX_SOURCE_COMPILES("
-#include <QtDBus>
-int main()
-{
-QDBusServiceWatcher watcher;
-return 0;
-}
-"
-HAVE_QDBUSSERVICEWATCHER)
-set(CMAKE_REQUIRED_LIBRARIES)
-
# Find python version >= 2.5
find_package(PythonLibrary REQUIRED)
set(REQUIRED_PY 2.5)