summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoe Konno <joe.konno@intel.com>2012-11-20 07:42:27 -0800
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-11-20 18:17:09 +0100
commiteb39abb70886d9277cf7d5114125cb7b22e7c362 (patch)
tree9b4d172c28871fa399d534fd420902a36cd7142e /configure.ac
parent63db874e9c924f086bcd3518cc0f3d8c6df9ecec (diff)
configure: add missing dependency to libm.
Build broke when trying to compile with expressive debug CFLAGS (-g3). This was root-caused to the lack of the "-lm" linker flag. By adding a simple autoconf check we ensure that libm is linked. More specifically, recent VEBOX changes depend on cos() and sin() math functions. Signed-off-by: Joe Konno <joe.konno@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4427839..2655d74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,7 @@ AM_PROG_CC_C_O
AC_C_BIGENDIAN
AC_HEADER_STDC
AC_SYS_LARGEFILE
+AC_CHECK_LIB([m], [sin])
LIBVA_PACKAGE_VERSION=libva_package_version
AC_SUBST(LIBVA_PACKAGE_VERSION)