summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGleb Popov <6yearold@gmail.com>2019-11-09 23:03:38 +0400
committerWim Taymans <wtaymans@redhat.com>2019-11-19 13:41:40 +0100
commitfd937fa37831c4f7ada03caa7461c65da923ace0 (patch)
tree9ab2e58e00661641d8c74cceb750731b27db0ee2 /meson.build
parent68e94a2e7e96f99b4659cf6ab3427c0971fb4b7b (diff)
On FreeBSD, add dependency on epoll-shim library.
FreeBSD doesn't provide timerfd and eventfd functions. These are implemented in 3rd party library called epoll-shim. Link targets requiring these functions to this library.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 83423040..2734b0d2 100644
--- a/meson.build
+++ b/meson.build
@@ -207,8 +207,12 @@ if get_option('gstreamer')
dependency('gstreamer-allocators-1.0'),]
endif
-subdir('spa')
+# On FreeBSD, epoll-shim library is required for eventfd() and timerfd()
+epoll_shim_dep = (build_machine.system() == 'freebsd'
+ ? dependency('epoll-shim', required: true)
+ : dependency('', required: false))
+subdir('spa')
subdir('src')
if get_option('pipewire-jack')