summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFrédéric Danis <frederic.danis@collabora.com>2020-07-22 14:50:38 +0200
committerWim Taymans <wtaymans@redhat.com>2020-07-22 18:59:58 +0200
commitdb0c224b060598d223e0cd49860a0e87e9f27355 (patch)
treee454db3bc1231f57fb820d969463092d1fc758c8 /meson.build
parentebdaac160c58ac107f41a71b6c9db51a8326624e (diff)
bluez5: Make native and ofono backends optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bff13f26..668f5330 100644
--- a/meson.build
+++ b/meson.build
@@ -254,6 +254,15 @@ if get_option('systemd')
endif
endif
+if get_option('bluez5')
+ if get_option('bluez5-backend-native')
+ cdata.set('HAVE_BLUEZ_5_BACKEND_NATIVE', 1)
+ endif
+ if get_option('bluez5-backend-ofono')
+ cdata.set('HAVE_BLUEZ_5_BACKEND_OFONO', 1)
+ endif
+endif
+
configure_file(input : 'config.h.meson',
output : 'config.h',
configuration : cdata)