summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWim Taymans <wtaymans@redhat.com>2020-03-27 08:27:11 -0400
committerWim Taymans <wtaymans@redhat.com>2020-03-27 08:27:11 -0400
commit67a5dd35be529c567d3b54460b213c061119bb32 (patch)
treef66c37e482aee93d752d767de4747935ea454aba /meson.build
parent397787ec3e9d44fd159df8b4fb8fb74fa710ac27 (diff)
resample: add neon optimizations
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 558ab4f2..2acf85e2 100644
--- a/meson.build
+++ b/meson.build
@@ -80,6 +80,21 @@ have_fma = cc.has_argument(fma_args)
have_avx = cc.has_argument(avx_args)
have_avx2 = cc.has_argument(avx2_args)
+have_neon = false
+if host_machine.cpu_family() == 'arm' or host_machine.cpu_family() == 'aarch64'
+ if cc.compiles(
+'''
+#include <arm_neon.h>
+int32x4_t testfunc(int16_t *a, int16_t *b) {
+return vmull_s16(vld1_s16(a), vld1_s16(b));
+}
+''',
+ name : 'NEON support')
+ have_neon = true
+ endif
+endif
+
+
cdata = configuration_data()
cdata.set('PIPEWIRE_VERSION_MAJOR', pipewire_version_major)
cdata.set('PIPEWIRE_VERSION_MINOR', pipewire_version_minor)