summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Rasmussen <sebras@hotmail.com>2014-11-15 13:26:47 +0100
committerSebastian Dröge <sebastian@centricular.com>2014-12-06 17:48:25 +0100
commit85c8b5d2c43be4888b12d31832823bf1cfc68c44 (patch)
tree74c936a3aee797ca60cc4145a6ecafc9040a20d3 /configure.ac
parentf1df7aba8fa0584ffb294a0e38e6c84596f177a5 (diff)
check: Apply GStreamer-specific patches
Reintroduced patches: * Make sure that fail_if(1) actually fails from commit 9f99d056a263e71a5e6181224829def906cf0226 New patches due to updated libcheck (based on 0.9.14): * Checks in m4/check-checks.m4 to cater for new dependencies * Conditional compile-time compat POSIX fallbacks for libcheck * Avoid relative paths for libcheck header files * Make timer_create() usage depend on posix timers, not librt * Rely on default AX_PTHREAD behavior to allow HAVE_PTHREAD to be used when checking for types and functions (like clock_gettime()) * Avoid double declaration of clock_gettime() when availabe outside of librt by making compat clock_gettime() declaration conditional * check 0.9.9 renamed _fail_unless() and 0.9.12 later renamed it again to _ck_assert_failed(), so ASSERT_{CRITICAL,WARNING}() now calls this function * Remove libcheck fallback infrastructure for malloc(), realloc(), gettimeofday() and snprintf() since either they appear to be available or they introduce even more dependencies. The result is an embedded check in gstreamer that has been tested by running check tests in core, -base, -good, -bad, -ugly and rtsp-server on Linux, OSX and Windows. Fixes https://bugzilla.gnome.org/show_bug.cgi?id=727826
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ab50a3ad7..24fac817a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -338,8 +338,10 @@ dnl Check for stdio_ext.f for __fbufsize
AC_CHECK_HEADERS([stdio_ext.h], [], [], [AC_INCLUDES_DEFAULT])
dnl check for pthreads
-AX_PTHREAD([HAVE_PTHREAD=yes], [HAVE_PTHREAD=no])
-AM_CONDITIONAL(HAVE_PTHREAD, test "x$HAVE_PTHREAD" = "xyes")
+dnl without arguments AX_PTHREAD() will do AC_DEFINE(HAVE_PTHREAD)
+dnl which later checks use in their test code
+AX_PTHREAD()
+AM_CONDITIONAL(HAVE_PTHREAD, test "x$ax_pthread_ok" = "xyes")
dnl check for sys/prctl for setting thread name on Linux
AC_CHECK_HEADERS([sys/prctl.h], [], [], [AC_INCLUDES_DEFAULT])