summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-03-30 15:20:07 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-03-30 15:20:07 +0100
commitb40320d48325674a21081155c7a917a5b9e7b473 (patch)
treeef6aa455a319cb1e159b72f7cbc723f2870d1a77 /Makefile.am
parent890042bc927d3ccb561b4814ae2befee7ecdd2d8 (diff)
build: make autotools put its m4 files into m4/ instead of common/m4/
This is how we do it in the other modules, and gets rid of the annoying dirty status for common when doing git status (at least once you clean out the old files from there).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 38 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5317b24bc..4f5a832c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc --enable-docbook
# note: keep in sync with configure.ac
-ACLOCAL_AMFLAGS = -I common/m4 -I .
+ACLOCAL_AMFLAGS = -I m4 -I common/m4
aclocaldir = $(datadir)/aclocal
aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
@@ -10,6 +10,7 @@ SUBDIRS = pkgconfig \
gst libs plugins tools tests \
docs \
po \
+ m4 \
common
# These are all the possible subdirs
@@ -17,6 +18,7 @@ DIST_SUBDIRS = pkgconfig \
gst libs plugins tools tests \
docs \
po \
+ m4 \
common
# include before EXTRA_DIST for win32 assignment
@@ -24,7 +26,6 @@ include $(top_srcdir)/common/win32.mak
EXTRA_DIST = \
gstreamer.spec gstreamer.spec.in \
- check-checks.m4 \
gst-element-check.m4.in \
configure.ac autogen.sh depcomp \
MAINTAINERS ABOUT-NLS RELEASE gstreamer.doap \
@@ -158,7 +159,41 @@ gst-element-check-@GST_MAJORMINOR@.m4: gst-element-check.m4
CRUFT_FILES = \
$(top_builddir)/common/shave \
- $(top_builddir)/common/shave-libtool
+ $(top_builddir)/common/shave-libtool \
+ $(top_builddir)/common/m4/codeset.m4 \
+ $(top_builddir)/common/m4/gettext.m4 \
+ $(top_builddir)/common/m4/glibc2.m4 \
+ $(top_builddir)/common/m4/glibc21.m4 \
+ $(top_builddir)/common/m4/iconv.m4 \
+ $(top_builddir)/common/m4/intdiv0.m4 \
+ $(top_builddir)/common/m4/intl.m4 \
+ $(top_builddir)/common/m4/intldir.m4 \
+ $(top_builddir)/common/m4/intlmacosx.m4 \
+ $(top_builddir)/common/m4/intmax.m4 \
+ $(top_builddir)/common/m4/inttypes-pri.m4 \
+ $(top_builddir)/common/m4/inttypes_h.m4 \
+ $(top_builddir)/common/m4/lcmessage.m4 \
+ $(top_builddir)/common/m4/lib-ld.m4 \
+ $(top_builddir)/common/m4/lib-link.m4 \
+ $(top_builddir)/common/m4/lib-prefix.m4 \
+ $(top_builddir)/common/m4/libtool.m4 \
+ $(top_builddir)/common/m4/lock.m4 \
+ $(top_builddir)/common/m4/longlong.m4 \
+ $(top_builddir)/common/m4/ltoptions.m4 \
+ $(top_builddir)/common/m4/ltsugar.m4 \
+ $(top_builddir)/common/m4/ltversion.m4 \
+ $(top_builddir)/common/m4/lt~obsolete.m4 \
+ $(top_builddir)/common/m4/nls.m4 \
+ $(top_builddir)/common/m4/po.m4 \
+ $(top_builddir)/common/m4/printf-posix.m4 \
+ $(top_builddir)/common/m4/progtest.m4 \
+ $(top_builddir)/common/m4/size_max.m4 \
+ $(top_builddir)/common/m4/stdint_h.m4 \
+ $(top_builddir)/common/m4/uintmax_t.m4 \
+ $(top_builddir)/common/m4/visibility.m4 \
+ $(top_builddir)/common/m4/wchar_t.m4 \
+ $(top_builddir)/common/m4/wint_t.m4 \
+ $(top_builddir)/common/m4/xsize.m4
include $(top_srcdir)/common/cruft.mak