summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@collabora.co.uk>2013-07-10 20:57:12 +0200
committerWim Taymans <wim.taymans@collabora.co.uk>2013-07-10 20:57:12 +0200
commit5c6bb3052fa79f2359fa9f712917086a016f4775 (patch)
treebecade744427eafd6cafb9c0d13352fba7be1f7a /configure.ac
parente788a9ca60fafc2bbf2b71ca9f1d9a3be92df26a (diff)
examples: add cgroups example
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d538367..aafa57f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,6 +229,10 @@ AC_SUBST([GST_OBJ_CFLAGS])
GST_OBJ_LIBS="\$(top_builddir)/gst/rtsp-server/libgstrtspserver-$GST_API_VERSION.la \$(GST_ALL_LIBS)"
AC_SUBST([GST_OBJ_LIBS])
+PKG_CHECK_MODULES(LIBCGROUP, libcgroup >= 0.26, HAVE_LIBCGROUP="yes", HAVE_LIBCGROUP="no")
+AC_SUBST(LIBCGROUP_CFLAGS)
+AC_SUBST(LIBCGROUP_LIBS)
+
dnl this really should only contain flags, not libs - they get added before
dnl whatevertarget_LIBS and -L flags here affect the rest of the linking