summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-09-26 14:30:00 +0100
committerTim-Philipp Müller <tim@centricular.com>2016-09-26 14:31:09 +0100
commit787f47604d7a1903b95e108fa977a6d7596219e8 (patch)
treec61860ed0ec8bb192526eeba6ac82b5c528304e0 /meson.build
parent7c5e89d82b7e1a7e090aa15509f14484e975ffa8 (diff)
meson: add unit tests
Only works properly in an installed setup currently, most likely won't work with a subprojects setup yet.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index fe6b3b9dd..c15c82d7d 100644
--- a/meson.build
+++ b/meson.build
@@ -130,6 +130,7 @@ cdata.set('PACKAGE_VERSION', '"@0@"'.format(gst_version))
cdata.set('GST_LICENSE', '"LGPL"')
cdata.set('PACKAGE', '"gst-plugins-good"')
cdata.set('GETTEXT_PACKAGE', '"gst-plugins-good-1.0"')
+cdata.set('PACKAGE_NAME', '"GStreamer Good Plug-ins"')
cdata.set('GST_PACKAGE_NAME', '"GStreamer Good Plug-ins"')
cdata.set('GST_PACKAGE_ORIGIN', '"Unknown package origin"') # FIXME: make configurable
@@ -149,6 +150,8 @@ gstpbutils_dep = dependency('gstreamer-pbutils-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'pbutils_dep'])
gstallocators_dep = dependency('gstreamer-allocators-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'allocators_dep'])
+gstapp_dep = dependency('gstreamer-app-1.0', version : gst_req,
+ fallback : ['gst-plugins-base', 'app_dep'])
gstaudio_dep = dependency('gstreamer-audio-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'audio_dep'])
gstfft_dep = dependency('gstreamer-fft-1.0', version : gst_req,
@@ -211,10 +214,6 @@ foreach d : deps
endif
endforeach
-if cc.has_header('valgrind.h')
- cdata.set('HAVE_VALGRIND', 1)
-endif
-
gst_plugins_good_args = ['-DHAVE_CONFIG_H']
configinc = include_directories('.')
libsinc = include_directories('gst-libs')