summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2009-03-10 12:53:03 -0400
committerDan Winship <danw@gnome.org>2009-03-12 10:04:25 -0400
commite01efd36358da845840a8a1d11422f622f8a7eee (patch)
tree015b6035d1154a22c8d0ba35996cf73d20221329 /Makefile.am
parent30a9c6b2f48af0f148704f2b1d20ad5b15e50486 (diff)
Make "make distcheck" work, and verify that we're disting all the javascript
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 685a80f9..2d20ae6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,18 @@
-SUBDIRS = src data
+SUBDIRS = data js src
+EXTRA_DIST = \
+ .project \
+ .settings
+distcheck-hook:
+ @echo "Checking disted javascript against files in git"
+ @failed=false; \
+ for f in `cd $(srcdir) && git-ls-files js` ; do \
+ if ! test -e $(distdir)/$$f ; then \
+ echo File missing from distribution: $$f ; \
+ failed=true ; \
+ fi \
+ done ; \
+ if $$failed ; then \
+ exit 1 ; \
+ fi