summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2011-06-28 10:21:24 +0100
committerJohan Hedberg <johan.hedberg@intel.com>2011-06-28 13:19:20 +0300
commitc98f635b446d0137f719612853a41e38fb43a1ff (patch)
treec4c2bb911bb0dc5fea3db6e09d5d768f2e8f86b8 /configure.ac
parent016df2cc8faed6cf088c27a5275fd52167123c0f (diff)
Add adaptername plugin
Replacing the name setting code in src/adapter.c. Moving the adapter naming allows us to use the /etc/machine-info [1] pretty hostname, as implemented by hostnamed [2] in systemd. If /etc/machine-info is not present, the adapter name stored on disk in /var/lib/bluetooth will be used. If no adapter name has been set yet, the default from the main.conf will be used. We don't currently number the name of hci0 if a pretty name is available, but we should instead number it if it happens not to be the default adapter. As we cannot be told when the default adapter changes, we'll behave this way for now. Note that when an adapter name is set automatically from the pretty hostname, changing it through the D-Bus interface will fail. [1]: http://0pointer.de/public/systemd-man/machine-info.html [2]: http://www.freedesktop.org/wiki/Software/systemd/hostnamed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2ce4acf3..223c9d1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,10 @@ AC_FUNC_PPOLL
AC_CHECK_LIB(dl, dlopen, dummy=yes,
AC_MSG_ERROR(dynamic linking loader is required))
+AC_CHECK_HEADER([sys/inotify.h],
+ [AC_DEFINE([HAVE_SYS_INOTIFY_H], 1,
+ [Define to 1 if you have <sys/inotify.h>.])],
+ [AC_MSG_ERROR(inotify headers are required and missing)])
AC_PATH_DBUS
AC_PATH_GLIB
AC_PATH_ALSA