summaryrefslogtreecommitdiff
path: root/protocol/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'protocol/Makefile.am')
-rw-r--r--protocol/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/protocol/Makefile.am b/protocol/Makefile.am
index 9c6cc49..4939557 100644
--- a/protocol/Makefile.am
+++ b/protocol/Makefile.am
@@ -1,7 +1,8 @@
if HAVE_XSLTPROC
-doc_DATA = wayland.html wayland-protocol.css
+dist_doc_DATA = wayland.html wayland-protocol.css wayland.xml
-wayland.html: wayland.xml protocol.xsl
- $(AM_V_GEN)$(XSLTPROC) protocol.xsl wayland.xml > $@
+wayland.html: $(srcdir)/wayland.xml $(srcdir)/protocol.xsl
+ $(AM_V_GEN)$(XSLTPROC) $(srcdir)/protocol.xsl $(srcdir)/wayland.xml > $@
+CLEANFILES = wayland.html
endif