summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-09-11 12:02:09 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-09-11 12:02:09 +0100
commit4c720bc262ea35b802606910b63b57f28929bdc6 (patch)
tree3b1f466abaa19717f66f71193f0edc804e59abf6 /configure.ac
parent36b4819e116fbbcca22c7c87d72d31353b6802bb (diff)
parent5c2184c21b1e8878394834a3b1ef9096a3c51087 (diff)
Merge branch 'telepathy-gabble-0.16'
Conflicts: NEWS configure.ac src/conn-addressing.c src/jingle-info.c src/media-channel-hold.c src/message-util.c src/muc-tube-dbus.c src/muc-tube-stream.c src/olpc-activity.c src/presence-cache.c src/protocol.c src/room-config.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 914116286..4340fd2fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,10 +148,6 @@ if test -n "$with_ca_certificates"; then
fi
fi
-# We are still using GValueArray which has been deprecated in GLib. Disable
-# GLib deprecation warnings as the only way to fix this is to switch to GDBus.
-AC_DEFINE(GLIB_DISABLE_DEPRECATION_WARNINGS, 1, [Build with GLib deprecated])
-
AC_ARG_ENABLE(debug,
AC_HELP_STRING([--disable-debug],[compile without debug code]),
enable_debug=$enableval, enable_debug=yes )
@@ -228,8 +224,11 @@ AM_CONDITIONAL([ENABLE_GTK_DOC], [test "x$enable_gtk_doc" = xyes])
dnl Check for Glib
PKG_CHECK_MODULES(GLIB,
- [glib-2.0 >= 2.24, gobject-2.0 >= 2.24, gthread-2.0 >= 2.24, gio-2.0])
-PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.24])
+ [glib-2.0 >= 2.30, gobject-2.0 >= 2.30, gthread-2.0 >= 2.30, gio-2.0])
+PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.30])
+
+AC_DEFINE(GLIB_VERSION_MIN_REQUIRED, GLIB_VERSION_2_30, [Ignore post 2.30 deprecations])
+AC_DEFINE(GLIB_VERSION_MAX_ALLOWED, GLIB_VERSION_2_30, [Prevent post 2.30 APIs])
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)