summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriel Burt <gabriel.burt@gmail.com>2009-12-11 12:51:13 -0800
committerGabriel Burt <gabriel.burt@gmail.com>2009-12-11 21:51:48 -0800
commitfb4f60f6718a9d802afc26e14d33d3b20ff380b4 (patch)
tree33cc9101ab7521389c3e803e8adadd529945a47a /Makefile.am
parentb02a0d60c5324df0fad3d9302bd669c0064317ff (diff)
Add make run-trace target to trace all method calls
Traces all calls for all methods defined in assemblies in bin/ except Mono.Data.Sqlite
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1c3e24be6..16e612b98 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,6 +52,11 @@ run-logged: $(MO_FILES)
run-perf: run-logged
extras/perf-analyze-log bin/last-run-log
+run-trace: $(MO_FILES)
+ (cd bin; $(MONO) \
+ --trace=$$(find . -name "*dll" | sed 's/\.\///' | sed 's/\.dll//' | sed 's/Mono.Data.Sqlite//' | sort | tr "\n" , | sed 's/,$$//') \
+ Nereid.exe --uninstalled $(BANSHEE_DEV_OPTIONS) > ../banshee.trace)
+
gdb:
@pushd bin; \
gdb mono --eval-command="handle SIGXCPU SIG35 SIGPWR nostop noprint" --eval-command="b g_return_if_fail_warning" --eval-command="r --debug Nereid.exe --debug --uninstalled"; \