summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriel Burt <gabriel.burt@gmail.com>2009-12-03 18:35:17 -0800
committerGabriel Burt <gabriel.burt@gmail.com>2009-12-03 18:35:17 -0800
commit9e5879044845a3962bcd97f6bbfe8aef07e1d2bb (patch)
tree9d860dd88bd480aa6dc619cc7d223b2a1ae77d34 /Makefile.am
parentdcef0c7ff1ca2d8cb6a8675197f6e2faa909fb5e (diff)
Bring back the glorious colored logging
Moved tee'd output to run-logged target, and updated run-perf target to use that.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c2c1d8aed..1c3e24be6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,9 +44,12 @@ $(MO_FILES): $(LC_BUILD)/%/LC_MESSAGES/$(PACKAGE).mo: po/%.gmo
cp -af '$<' '$@'
run: $(MO_FILES)
+ (cd bin; $(MONO) --debug $(BANSHEE_DEV_MONO_OPTIONS) Nereid.exe --debug --uninstalled $(BANSHEE_DEV_OPTIONS))
+
+run-logged: $(MO_FILES)
(cd bin; $(MONO) --debug $(BANSHEE_DEV_MONO_OPTIONS) Nereid.exe --debug --uninstalled $(BANSHEE_DEV_OPTIONS) | tee last-run-log)
-run-perf: run
+run-perf: run-logged
extras/perf-analyze-log bin/last-run-log
gdb: