summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriel Burt <gabriel.burt@gmail.com>2008-03-30 23:53:15 +0000
committerGabriel Burt <gburt@src.gnome.org>2008-03-30 23:53:15 +0000
commit930cf68120233704f05d1b6d11356666da42bb99 (patch)
tree70dfc66822de3ba759203c30b03ebd21f40ab01b /Makefile.am
parentb1f215f854a5e9177c112e08d8b6842645413d74 (diff)
This commit adds Jump to Playing support, and hides the search box for
2008-03-30 Gabriel Burt <gabriel.burt@gmail.com> This commit adds Jump to Playing support, and hides the search box for sources that can't be search. * Makefile.am: Add make test target. * src/Clients/Nereid/Nereid/ViewContainer.cs: Keep the visibility of the search entry tied to whether its sensitive (eg hide if !source.CanSearch). * src/Clients/Nereid/Nereid/PlayerInterface.cs: When changing the active source is changed, if the view used implements the new ITrackModelSourceContents interface, set some properties on the source itself linking ith with the Track/Artist/Album views. * src/Core/Banshee.Services/Banshee.Sources/SourceManager.cs: Be even more defensive when setting the active source. * src/Core/Banshee.ThickClient/Resources/core-ui-actions-layout.xml: * src/Core/Banshee.ThickClient/Banshee.Gui/PlaybackActions.cs: Add Jump to Playing Song/Video action. * src/Core/Banshee.ThickClient/Makefile.am: * src/Core/Banshee.ThickClient/Banshee.Sources.Gui/ITrackModelSourceContents.cs: New interface for source contents that have track, artist, and album IListView<T>s. * src/Core/Banshee.ThickClient/Banshee.Sources.Gui/CompositeTrackSourceContents.cs: Implement ITrackModelSourceContents. * src/Libraries/Hyena.Gui/Makefile.am: * src/Libraries/Hyena.Gui/Hyena.Data.Gui/IListView.cs: New interface that ListView implements. Will allow us to implement alternative views for track/artist/albums but still have some sharing functionality (like jump to playing track). * src/Libraries/Hyena.Gui/Hyena.Data.Gui/Column.cs: Fix newlines. * src/Libraries/Hyena.Gui/Hyena.Data.Gui/ListView/ListView.cs: Implement IListView. * src/Libraries/Hyena.Gui/Hyena.Data.Gui/ListView/ListView_Interaction.cs: Change ScrollToRow to ScrollTo, and add CenterOn method (both implementing IListView). * src/Libraries/Hyena.Gui/Hyena.Data.Gui/ListView/ListView_Model.cs: Use CenterOn method instead of implementing it here too. svn path=/trunk/banshee/; revision=3605
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a9ba6f02..de65e4cbc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,6 +64,11 @@ run:
$(MONO) --debug $(BANSHEE_DEV_MONO_OPTIONS) Nereid.exe --debug --uninstalled $(BANSHEE_DEV_OPTIONS); \
popd;
+test:
+ @pushd tests; \
+ make run-test \
+ popd;
+
clean-local:
rm -rf $(top_builddir)/bin