summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAaron Bockover <abock@gnome.org>2008-04-17 00:14:12 +0000
committerAaron Bockover <abock@src.gnome.org>2008-04-17 00:14:12 +0000
commit4ff5a8a178975707461ebc59d60ede388f3709d2 (patch)
tree38152d2f2e5479929eec6673975e49c1e9703342 /Makefile.am
parent20a47b74285981f350bc9f863dd2b15c99f40287 (diff)
Add a gdb target
2008-04-16 Aaron Bockover <abock@gnome.org> * Makefile.am: Add a gdb target * src/Core/Banshee.ThickClient/Banshee.Gui/BansheeActionGroup.cs: Added AddImportant override for ToggleActionEntry * src/Core/Banshee.ThickClient/Banshee.Gui/BaseClientWindow.cs: Moved the fullscreen code * src/Core/Banshee.hickClient/Banshee.Gui/ViewActions.cs: Implement the fullscreen action and allow the fullscreen logic to be overridden * src/Extensions/Banshee.NowPlaying/Banshee.NowPlaying/FullscreenWindow.cs: The window that will house the fullscreen UI for video playback * src/Extensions/Banshee.NowPlaying/Banshee.NowPlaying/NowPlayingInterface.cs: Add a property for getting the VideoDisplay widget * src/Extensions/Banshee.NowPlaying/Banshee.NowPlaying/NowPlayingSource.cs: Added a custom fullscreen handler that will fullscreen the video window when fullscreen action is toggled and the now playing source is active * src/Extensions/Banshee.NowPlaying/Banshee.NowPlaying/VideoDisplay.cs: Inherit from GtkEventBox since it does what we needed and simplifies some things; still has that CRITICAL warning though * src/Extensions/Banshee.NowPlaying/Resources/ActiveSourceUI.xml: UI for merging the fullscreen action into the toolbar svn path=/trunk/banshee/; revision=3789
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 200db87e8..0706739e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,6 +64,11 @@ run:
$(MONO) --debug $(BANSHEE_DEV_MONO_OPTIONS) Nereid.exe --debug --uninstalled $(BANSHEE_DEV_OPTIONS); \
popd;
+gdb:
+ @pushd bin; \
+ gdb mono --eval-command="handle SIGXCPU SIG35 SIGPWR nostop noprint" --eval-command="b g_return_if_fail_warning" --eval-command="r --debug Nereid.exe --debug --uninstalled"; \
+ popd;
+
test:
@pushd tests; \
make test \